Merge branch 'master' of mmka:unres into multichain
[unres.git] / source / wham / src / CMakeLists.txt
index e7f990e..d441588 100644 (file)
@@ -94,7 +94,7 @@ set(UNRES_WHAM_PP_SRC
 # Set comipiler flags for different sourcefiles  
 #================================================
 if (Fortran_COMPILER_NAME STREQUAL "ifort")
-  set(FFLAGS0 "-mcmodel=medium -g -CB -I. -I${CMAKE_CURRENT_SOURCE_DIR}/include_unres" ) 
+  set(FFLAGS0 "-mcmodel=large -g -CB -I. -I${CMAKE_CURRENT_SOURCE_DIR}/include_unres" ) 
 elseif (Fortran_COMPILER_NAME STREQUAL "gfortran")
   set(FFLAGS0 "-std=legacy -g -I. -I${CMAKE_CURRENT_SOURCE_DIR}/include_unres" ) 
 else ()
@@ -154,6 +154,9 @@ elseif (Fortran_COMPILER_NAME STREQUAL "f95")
 elseif (Fortran_COMPILER_NAME STREQUAL "gfortran")
   # Add old gfortran flags
   set(CPPFLAGS "${CPPFLAGS} -DG77") 
+else (Fortran_COMPILER_NAME STREQUAL "ifort")
+  # Default preprocessor flags 
+  set(CPPFLAGS "${CPPFLAGS} -DPGI")
 endif (Fortran_COMPILER_NAME STREQUAL "ifort")
 
 #=========================================