src_MD-M CMake build files + junkfiles cleanup
[unres.git] / source / unres / src_MD / CMakeLists.txt
index 424d56f..bea362d 100644 (file)
@@ -122,7 +122,9 @@ endif(UNRES_WITH_MPI)
 #  - shame on me ]:)
 #=========================================
 set_property(SOURCE compinfo.c PROPERTY CMAKE_C_FLAGS "-c" )
-add_executable(compinfo compinfo.c)
+add_executable(compinfo-md compinfo.c)
+set_target_properties(compinfo-md PROPERTIES OUTPUT_NAME compinfo)
+
 set(UNRES_CINFO_DIR "${CMAKE_CURRENT_BINARY_DIR}" )
 add_custom_command(OUTPUT ${CMAKE_CURRENT_BINARY_DIR}/cinfo.f 
        COMMAND ${CMAKE_COMMAND} -E copy ${CMAKE_CURRENT_SOURCE_DIR}/cinfo.f ${CMAKE_CURRENT_BINARY_DIR}/cinfo.f
@@ -141,7 +143,8 @@ set(UNRES_MD_SRCS ${UNRES_MD_SRC0} ${UNRES_MD_SRC3} ${UNRES_CINFO_DIR}/cinfo.f )
 #=========================================
 # Build the binary
 #=========================================
-add_executable(${UNRES_BIN} ${UNRES_MD_SRCS} )
+add_executable(UNRES_BIN-MD ${UNRES_MD_SRCS} )
+set_target_properties(UNRES_BIN-MD PROPERTIES OUTPUT_NAME ${UNRES_BIN})
 #set_property(TARGET ${UNRES_BIN} PROPERTY RUNTIME_OUTPUT_DIRECTORY ${CMAKE_BINARY_DIR}/bin/unres/MD )
 #add_dependencies (${UNRES_BIN} ${UNRES_XDRFLIB})
 
@@ -150,11 +153,11 @@ add_executable(${UNRES_BIN} ${UNRES_MD_SRCS} )
 #=========================================
 # link MPI library (libmpich.a)  
 if(UNRES_WITH_MPI)
-  target_link_libraries( ${UNRES_BIN} ${MPIF_LIBRARIES} )
+  target_link_libraries( UNRES_BIN-MD ${MPIF_LIBRARIES} )
 endif(UNRES_WITH_MPI)
 # link libxdrf.a 
 #message("UNRES_XDRFLIB=${UNRES_XDRFLIB}")
-target_link_libraries( ${UNRES_BIN} xdrf )
+target_link_libraries( UNRES_BIN-MD xdrf )
 
 #=========================================
 # TESTS