added default preprocessor flags for unknown compilers
[unres.git] / source / unres / src_MD / CMakeLists.txt
index a0353f4..7dc7135 100644 (file)
@@ -212,6 +212,9 @@ elseif (Fortran_COMPILER_NAME STREQUAL "f95")
 elseif (Fortran_COMPILER_NAME STREQUAL "gfortran")
   # Add old gfortran flags
   set(CPPFLAGS "${CPPFLAGS} -DG77") 
+else(Fortran_COMPILER_NAME STREQUAL "ifort")
+  # Default preprocessor flag
+  set(CPPFLAGS "${CPPFLAGS} -DPGI")
 endif (Fortran_COMPILER_NAME STREQUAL "ifort")
 
 #=========================================