fixed install binary paths
[unres.git] / source / unres / src_MD / CMakeLists.txt
index 0b173f6..3d97d54 100644 (file)
@@ -166,7 +166,7 @@ set_property(SOURCE ${UNRES_MD_SRC3} PROPERTY COMPILE_FLAGS ${FFLAGS3} )
 #=========================================
 if(UNRES_MD_FF STREQUAL "GAB" )
   # set preprocesor flags   
-  set(CPPFLAGS "PROCOR -DUNRES -DISNAN -DSPLITELE -DLANG0 -DCRYST_BOND -DCRYST_THETA -DCRYST_SC" )
+  set(CPPFLAGS "PROCOR -DUNRES -DISNAN -DSPLITELE -DLANG0 -DCRYST_BOND -DCRYST_THETA -DCRYST_SC")
 
 #=========================================
 #  Settings for E0LL2Y force field
@@ -290,7 +290,7 @@ target_link_libraries( UNRES_BIN-MD xdrf )
 #=========================================
 # Install Path
 #=========================================
-install(TARGETS UNRES_BIN-MD DESTINATION ${CMAKE_INSTALL_PREFIX}) 
+install(TARGETS UNRES_BIN-MD DESTINATION ${CMAKE_INSTALL_PREFIX}/unres/MD) 
 
 #=========================================
 # TESTS 
@@ -322,7 +322,7 @@ FILE(WRITE ${CMAKE_CURRENT_BINARY_DIR}/scripts/test_single_ala.sh
 export POT=GB
 export PREFIX=ala10
 #-----------------------------------------------------------------------------
-UNRES_BIN=./${UNRES_BIN}
+UNRES_BIN=${CMAKE_BINARY_DIR}/bin/${UNRES_BIN}
 #-----------------------------------------------------------------------------
 DD=${CMAKE_SOURCE_DIR}/PARAM
 export BONDPAR=$DD/bond.parm