1) binaries are compiled into /bin subdirectory of build directory
[unres.git] / source / unres / src_MD / CMakeLists.txt
index f0f1123..0b173f6 100644 (file)
@@ -223,10 +223,10 @@ set_property(SOURCE ${UNRES_MD_PP_SRC} PROPERTY COMPILE_DEFINITIONS ${CPPFLAGS}
 #========================================
 if(UNRES_WITH_MPI) 
   # binary with mpi
-  set(UNRES_BIN "unres_${Fortran_COMPILER_NAME}_MPICH_${UNRES_MD_FF}.exe")
+  set(UNRES_BIN "unresMD_${Fortran_COMPILER_NAME}_MPICH_${UNRES_MD_FF}.exe")
 else(UNRES_WITH_MPI)
   # binary without mpi
-  set(UNRES_BIN "unres_${Fortran_COMPILER_NAME}_single_${UNRES_MD_FF}.exe")
+  set(UNRES_BIN "unresMD_${Fortran_COMPILER_NAME}_single_${UNRES_MD_FF}.exe")
 endif(UNRES_WITH_MPI)  
 
 #=========================================
@@ -272,7 +272,7 @@ set(UNRES_MD_SRCS ${UNRES_MD_SRC0} ${UNRES_MD_SRC3} ${CMAKE_CURRENT_BINARY_DIR}/
 #=========================================
 add_executable(UNRES_BIN-MD ${UNRES_MD_SRCS} )
 set_target_properties(UNRES_BIN-MD PROPERTIES OUTPUT_NAME ${UNRES_BIN})
-#set_property(TARGET ${UNRES_BIN} PROPERTY RUNTIME_OUTPUT_DIRECTORY ${CMAKE_BINARY_DIR}/bin/unres/MD )
+set_property(TARGET UNRES_BIN-MD PROPERTY RUNTIME_OUTPUT_DIRECTORY ${CMAKE_BINARY_DIR}/bin )
 #add_dependencies (${UNRES_BIN} ${UNRES_XDRFLIB})
 
 
@@ -288,6 +288,11 @@ endif(UNRES_WITH_MPI)
 target_link_libraries( UNRES_BIN-MD xdrf )
 
 #=========================================
+# Install Path
+#=========================================
+install(TARGETS UNRES_BIN-MD DESTINATION ${CMAKE_INSTALL_PREFIX}) 
+
+#=========================================
 # TESTS 
 #=========================================