added missing preprocessor flags for prng_32.F
[unres.git] / source / unres / src_MD / CMakeLists.txt
index 49f3869..e2b4934 100644 (file)
@@ -206,6 +206,13 @@ if (UNRES_WITH_MPI)
 endif(UNRES_WITH_MPI)
 
 #=========================================
+# Add 64-bit specific preprocessor flags
+#=========================================
+if (architektura STREQUAL "64")
+  set(CPPFLAGS "${CPPFLAGS} -DAMD64")
+endif (architektura STREQUAL "64")
+
+#=========================================
 # Apply preprocesor flags to *.F files
 #=========================================
 set_property(SOURCE ${UNRES_MD_PP_SRC} PROPERTY COMPILE_DEFINITIONS ${CPPFLAGS} )