Merge branch 'lipid' of mmka.chem.univ.gda.pl:unres into lipid
[unres.git] / source / unres / src_MD / CMakeLists.txt
index 8d21134..a228d16 100644 (file)
@@ -72,6 +72,7 @@ set(UNRES_MD_SRC0
        rmsd.F 
        sc_move.F 
        sort.f 
+       ssMD.F
        stochfric.F 
        sumsld.f 
        surfatom.f 
@@ -79,7 +80,6 @@ set(UNRES_MD_SRC0
        timing.F
        thread.F 
        unres.F
-       ssMD.F
 )
 
 set(UNRES_MD_SRC3 
@@ -122,6 +122,7 @@ set(UNRES_MD_PP_SRC
        regularize.F 
        rmsd.F 
        sc_move.F 
+       ssMD.F
        stochfric.F 
        test.F 
        thread.F 
@@ -301,7 +302,7 @@ target_link_libraries( UNRES_BIN-MD xdrf )
 #=========================================
 # Install Path
 #=========================================
-install(TARGETS UNRES_BIN-MD DESTINATION ${CMAKE_INSTALL_PREFIX}) 
+install(TARGETS UNRES_BIN-MD DESTINATION ${CMAKE_INSTALL_PREFIX}/unres/MD) 
 
 #=========================================
 # TESTS 
@@ -327,6 +328,13 @@ install(TARGETS UNRES_BIN-MD DESTINATION ${CMAKE_INSTALL_PREFIX})
 #=========================================
 #  test_single_ala.sh
 #=========================================
+#
+# Set parmaeters depending on force field
+if(UNRES_MD_FF STREQUAL "GAB")
+   set(UNRES_BONDPAR "bond.parm")      
+elseif(UNRES_MD_FF STREQUAL "E0LL2Y")
+   set(UNRES_BONDPAR "bond_AM1.parm")
+endif(UNRES_MD_FF STREQUAL "GAB")
 
 FILE(WRITE ${CMAKE_CURRENT_BINARY_DIR}/scripts/test_single_ala.sh
 "#!/bin/sh
@@ -336,7 +344,7 @@ export PREFIX=ala10
 UNRES_BIN=${CMAKE_BINARY_DIR}/bin/${UNRES_BIN}
 #-----------------------------------------------------------------------------
 DD=${CMAKE_SOURCE_DIR}/PARAM
-export BONDPAR=$DD/bond.parm
+export BONDPAR=$DD/${UNRES_BONDPAR}
 export THETPAR=$DD/thetaml.5parm
 export ROTPAR=$DD/scgauss.parm
 export TORPAR=$DD/torsion_631Gdp.parm