fixed binary names for cmake and make
[unres.git] / source / unres / src_MD-M / CMakeLists.txt
index ecd2b5a..e4c3c08 100644 (file)
@@ -256,10 +256,10 @@ set_property(SOURCE proc_proc.c PROPERTY COMPILE_DEFINITIONS "SGI" )
 #========================================
 if(UNRES_WITH_MPI) 
   # binary with mpi
-  set(UNRES_BIN "unresMD-M_${Fortran_COMPILER_NAME}_MPICH_${UNRES_MD_FF}.exe")
+  set(UNRES_BIN "unresMD-mult_${Fortran_COMPILER_NAME}_MPI_${UNRES_MD_FF}.exe")
 else(UNRES_WITH_MPI)
   # binary without mpi
-  set(UNRES_BIN "unresMD-M_${Fortran_COMPILER_NAME}_single_${UNRES_MD_FF}.exe")
+  set(UNRES_BIN "unresMD-mult_${Fortran_COMPILER_NAME}_single_${UNRES_MD_FF}.exe")
 endif(UNRES_WITH_MPI)  
 
 #=========================================
@@ -321,7 +321,7 @@ target_link_libraries( UNRES_BIN-MD-M xdrf )
 #=========================================
 # Install Path
 #=========================================
-install(TARGETS UNRES_BIN-MD-M DESTINATION ${CMAKE_INSTALL_PREFIX})
+install(TARGETS UNRES_BIN-MD-M DESTINATION ${CMAKE_INSTALL_PREFIX}/unres/MD)
 
 #=========================================
 # TESTS