ctest works with lam mpi
[unres.git] / source / unres / src_MD-M / CMakeLists.txt
index 28bdae4..ce09ea7 100644 (file)
@@ -505,6 +505,15 @@ $UNRES_BIN
 ./prota_unres_energy_check.sh $1 ${UNRES_BIN}
 ")
 
+#  MESSAGE (STATUS "${MPI_Fortran_LIBRARIES}")
+  if ("${MPI_Fortran_LIBRARIES}"  MATCHES "lam")
+     MESSAGE (STATUS "LAM MPI library detected")
+     set (boot_lam "-boot")
+  else()
+     set (boot_lam "")
+  endif()
+
+
 #
 # File permissions workaround
 #
@@ -537,7 +546,7 @@ export ROTPARPDB=$DD/scgauss.parm
 export PATTERN=$DD/patterns.cart
 #-----------------------------------------------------------------------------
 echo CTEST_FULL_OUTPUT
-mpiexec -np $3 $UNRES_BIN | grep -v traj1file
+mpiexec ${boot_lam} -np $3 $UNRES_BIN | grep -v traj1file
 ./prota_unres_energy_check.sh $1 ${UNRES_BIN}
 ")
 
@@ -581,13 +590,6 @@ if(NOT UNRES_WITH_MPI)
 
 else(NOT UNRES_WITH_MPI)
 
-#  MESSAGE (STATUS "${MPI_Fortran_LIBRARIES}")
-  if ("${MPI_Fortran_LIBRARIES}"  MATCHES "lam")
-     MESSAGE (STATUS "LAM MPI library detected")
-     set (boot_lam "-boot")
-  else()
-     set (boot_lam "")
-  endif()
 
   if(UNRES_MD_FF STREQUAL "GAB")
     add_test(NAME UNRES_M_MD_MPI_Ala10 COMMAND mpiexec ${boot_lam} ${CMAKE_CURRENT_BINARY_DIR}/test_single_ala.sh )