correction in multichain
[unres.git] / source / unres / src_MD-M / CMakeLists.txt
index eed7732..6b1b37e 100644 (file)
@@ -192,14 +192,14 @@ set_property(SOURCE ${UNRES_MDM_SRC3} PROPERTY COMPILE_FLAGS ${FFLAGS3} )
 #=========================================
 if(UNRES_MD_FF STREQUAL "GAB" )
   # set preprocesor flags   
-  set(CPPFLAGS "PROCOR -DUNRES -DISNAN -DSPLITELE -DLANG0 -DCRYST_BOND -DCRYST_THETA -DCRYST_SC" )
+  set(CPPFLAGS "PROCOR -DUNRES -DISNAN -DSPLITELE -DLANG0 -DCRYST_BOND -DCRYST_THETA -DCRYST_SC  -DSCCORPDB" )
 
 #=========================================
 #  Settings for E0LL2Y force field
 #=========================================
 elseif(UNRES_MD_FF STREQUAL "E0LL2Y")
   # set preprocesor flags   
-  set(CPPFLAGS "PROCOR -DUNRES -DISNAN -DSPLITELE -DLANG0" )
+  set(CPPFLAGS "PROCOR -DUNRES -DISNAN -DSPLITELE -DLANG0 -DSCCORPDB" )
 endif(UNRES_MD_FF STREQUAL "GAB")
 
 
@@ -224,6 +224,9 @@ elseif (Fortran_COMPILER_NAME STREQUAL "f95")
 elseif (Fortran_COMPILER_NAME STREQUAL "gfortran")
   # Add old gfortran flags
   set(CPPFLAGS "${CPPFLAGS} -DG77") 
+else (Fortran_COMPILER_NAME STREQUAL "ifort")
+  # Default preprocessor flags
+  set(CPPFLAGS "${CPPFLAGS} -DPGI")
 endif (Fortran_COMPILER_NAME STREQUAL "ifort")
 
 
@@ -256,10 +259,10 @@ set_property(SOURCE proc_proc.c PROPERTY COMPILE_DEFINITIONS "SGI" )
 #========================================
 if(UNRES_WITH_MPI) 
   # binary with mpi
-  set(UNRES_BIN "unres_${Fortran_COMPILER_NAME}_MPICH_${UNRES_MD_FF}.exe")
+  set(UNRES_BIN "unresMD-M_${Fortran_COMPILER_NAME}_MPICH_${UNRES_MD_FF}.exe")
 else(UNRES_WITH_MPI)
   # binary without mpi
-  set(UNRES_BIN "unres_${Fortran_COMPILER_NAME}_single_${UNRES_MD_FF}.exe")
+  set(UNRES_BIN "unresMD-M_${Fortran_COMPILER_NAME}_single_${UNRES_MD_FF}.exe")
 endif(UNRES_WITH_MPI)  
 
 #=========================================
@@ -304,8 +307,7 @@ set(UNRES_MDM_SRCS ${UNRES_MDM_SRC0} ${UNRES_MDM_SRC3} ${CMAKE_CURRENT_BINARY_DI
 #=========================================
 add_executable(UNRES_BIN-MD-M ${UNRES_MDM_SRCS} )
 set_target_properties(UNRES_BIN-MD-M PROPERTIES OUTPUT_NAME ${UNRES_BIN})
-
-#set_property(TARGET ${UNRES_BIN} PROPERTY RUNTIME_OUTPUT_DIRECTORY ${CMAKE_BINARY_DIR}/bin/unres/MD )
+set_property(TARGET UNRES_BIN-MD-M PROPERTY RUNTIME_OUTPUT_DIRECTORY ${CMAKE_BINARY_DIR}/bin )
 #add_dependencies (${UNRES_BIN} ${UNRES_XDRFLIB})
 
 #=========================================
@@ -320,6 +322,11 @@ endif(UNRES_WITH_MPI)
 target_link_libraries( UNRES_BIN-MD-M xdrf )
 
 #=========================================
+# Install Path
+#=========================================
+install(TARGETS UNRES_BIN-MD-M DESTINATION ${CMAKE_INSTALL_PREFIX})
+
+#=========================================
 # TESTS 
 #=========================================