added default preprocessor flags for unknown compilers
[unres.git] / source / unres / src_MD-M / CMakeLists.txt
index 63137a5..66264be 100644 (file)
@@ -235,6 +235,9 @@ elseif (Fortran_COMPILER_NAME STREQUAL "f95")
 elseif (Fortran_COMPILER_NAME STREQUAL "gfortran")
   # Add old gfortran flags
   set(CPPFLAGS "${CPPFLAGS} -DG77") 
+else (Fortran_COMPILER_NAME STREQUAL "ifort")
+  # Default preprocessor flags
+  set(CPPFLAGS "${CPPFLAGS} -DPGI")
 endif (Fortran_COMPILER_NAME STREQUAL "ifort")