1) binaries are compiled into /bin subdirectory of build directory
[unres.git] / source / unres / src_CSA_DiL / CMakeLists.txt
index 7f4f3ab..ae64a42 100644 (file)
@@ -194,7 +194,7 @@ set_property(SOURCE ${UNRES_CSA_DiL_PP_SRC} PROPERTY COMPILE_DEFINITIONS ${CPPFL
 #========================================
 #  Setting binary name
 #========================================
-set(UNRES_BIN "unresCSA_${Fortran_COMPILER_NAME}_${UNRES_CSA_FF}_DiL.exe")
+set(UNRES_BIN "unresCSA_DiL_${Fortran_COMPILER_NAME}_${UNRES_CSA_FF}.exe")
 
 #=========================================
 # cinfo.f workaround for CMake
@@ -238,8 +238,7 @@ set(UNRES_CSA_DiL_SRCS ${UNRES_CSA_DiL_SRC0} ${UNRES_CSA_DiL_SRC3} ${CMAKE_CURRE
 #=========================================
 add_executable(UNRES_BIN-CSA-DIL ${UNRES_CSA_DiL_SRCS} )
 set_target_properties(UNRES_BIN-CSA-DIL PROPERTIES OUTPUT_NAME ${UNRES_BIN})
-
-#set_property(TARGET ${UNRES_BIN} PROPERTY RUNTIME_OUTPUT_DIRECTORY ${CMAKE_BINARY_DIR}/bin/unres/MD )
+set_property(TARGET UNRES_BIN-CSA-DIL PROPERTY RUNTIME_OUTPUT_DIRECTORY ${CMAKE_BINARY_DIR}/bin )
 
 #=========================================
 # Link libraries
@@ -248,6 +247,12 @@ set_target_properties(UNRES_BIN-CSA-DIL PROPERTIES OUTPUT_NAME ${UNRES_BIN})
 target_link_libraries( UNRES_BIN-CSA-DIL ${MPI_Fortran_LIBRARIES} )
 
 #=========================================
+# Install Path
+#=========================================
+install(TARGETS UNRES_BIN-CSA-DIL DESTINATION ${CMAKE_INSTALL_PREFIX})
+
+
+#=========================================
 # TESTS 
 #=========================================