1) binaries are compiled into /bin subdirectory of build directory
[unres.git] / source / unres / src_CSA / CMakeLists.txt
index 445b8ac..d3db081 100644 (file)
@@ -235,8 +235,7 @@ set(UNRES_CSA_SRCS ${UNRES_CSA_SRC0} ${UNRES_CSA_SRC3} ${CMAKE_CURRENT_BINARY_DI
 #=========================================
 add_executable(UNRES_BIN-CSA ${UNRES_CSA_SRCS} )
 set_target_properties(UNRES_BIN-CSA PROPERTIES OUTPUT_NAME ${UNRES_BIN})
-
-#set_property(TARGET ${UNRES_BIN} PROPERTY RUNTIME_OUTPUT_DIRECTORY ${CMAKE_BINARY_DIR}/bin/unres/MD )
+set_property(TARGET UNRES_BIN-CSA PROPERTY RUNTIME_OUTPUT_DIRECTORY ${CMAKE_BINARY_DIR}/bin )
 #add_dependencies (${UNRES_BIN} ${UNRES_XDRFLIB})
 
 #=========================================
@@ -248,6 +247,12 @@ target_link_libraries( UNRES_BIN-CSA ${MPI_Fortran_LIBRARIES} )
 #target_link_libraries( ${UNRES_BIN} xdrf )
 
 #=========================================
+# Install Path
+#=========================================
+install(TARGETS UNRES_BIN-CSA DESTINATION ${CMAKE_INSTALL_PREFIX})
+
+
+#=========================================
 # TESTS 
 #=========================================