fixed binary names for cmake and make
[unres.git] / source / unres / src_CSA / CMakeLists.txt
index 1ae7730..340fd7c 100644 (file)
@@ -149,6 +149,10 @@ elseif(UNRES_CSA_FF STREQUAL "3P")
   set(CPPFLAGS "UNRES -DISNAN -DSPLITELE -DLANG0 -DCRYST_BOND -DCRYST_THETA -DCRYST_SC -DSCCORPDB" )
 elseif(UNRES_CSA_FF STREQUAL "4P")
   set(CPPFLAGS "UNRES -DISNAN -DSPLITELE -DLANG0 -DCRYST_BOND -DCRYST_THETA -DCRYST_SC -DSCCORPDB" )
+elseif(UNRES_CSA_FF STREQUAL "GAB" )
+  set(CPPFLAGS "PROCOR -DUNRES -DISNAN -DSPLITELE -DLANG0 -DCRYST_BOND -DCRYST_THETA -DCRYST_SC" )
+elseif(UNRES_CSA_FF STREQUAL "E0LL2Y" )
+  set(CPPFLAGS "PROCOR -DUNRES -DISNAN -DSPLITELE -DLANG0" )
 endif(UNRES_CSA_FF STREQUAL "CASP3")
 
 #=========================================
@@ -192,7 +196,7 @@ set_property(SOURCE ${UNRES_CSA_PP_SRC} PROPERTY COMPILE_DEFINITIONS ${CPPFLAGS}
 #========================================
 #  Setting binary name
 #========================================
-set(UNRES_BIN "unresCSA_${Fortran_COMPILER_NAME}_${UNRES_CSA_FF}.exe")
+set(UNRES_BIN "unresCSA_${Fortran_COMPILER_NAME}_MPI_${UNRES_CSA_FF}.exe")
 
 #=========================================
 # cinfo.f workaround for CMake