5D update
[unres.git] / source / unres / src-HCD-5D / CMakeLists.txt
index 96c0eb3..5e55fbd 100644 (file)
@@ -14,7 +14,6 @@ set(UNRES_MDM_SRC0
         bank.F 
         blas.f 
         bond_move.f 
-        cartder.F 
         cartprint.f 
         chainbuild.F 
         check_bond.f 
@@ -43,12 +42,11 @@ set(UNRES_MDM_SRC0
         initialize_p.F 
         intcartderiv.F
         intcor.f 
-        intlocal.f 
         int_to_cart.f 
-        kinetic_lesyng.f 
+        kinetic_lesyng.F
         lagrangian_lesyng.F
         local_move.f 
-        map.f 
+        map.F 
         matmult.f 
         mc.F 
         mcm.F 
@@ -57,10 +55,10 @@ set(UNRES_MDM_SRC0
         minim_jlee.F 
         minim_mcmf.F 
         misc.f 
-        moments.f
+        moments.F
         MP.F 
         MREMD.F 
-        muca_md.f 
+        muca_md.F 
         newconf.f
         parmread.F 
         permut.F
@@ -84,7 +82,6 @@ set(UNRES_MDM_SRC0
         stochfric.F 
         sumsld.f 
         surfatom.f 
-        test.F 
         thread.F 
         timing.F
         together.F
@@ -98,13 +95,18 @@ set(UNRES_MDM_SRC0
         seq2chains.f
         iperm.f
         PMFprocess.F
+         cart2intgrad.F
+         inform.f iounit.f keys.f linmin.f math.f 
+         minima.f scales.f output.f lbfgs.F
+         search.f optsave_dum.f
+         fdisy.f fdiag.f machpd.f kinetic_CASC.F
+         contact_cp.F
 )
 
 set(UNRES_MDM_SRC3 energy_p_new_barrier.F energy_p_new-sep_barrier.F gradient_p.F )
 
 set(UNRES_MDM_PP_SRC
        bank.F 
-       cartder.F 
        chainbuild.F 
        checkder_p.F 
        compare_s1.F
@@ -152,7 +154,6 @@ set(UNRES_MDM_PP_SRC
        shift.F 
        stochfric.F
        sumsld.f 
-       test.F 
        thread.F 
        timing.F
        together.F
@@ -163,6 +164,14 @@ set(UNRES_MDM_PP_SRC
        rmscalc.F
        chain_symmetry.F
        PMFprocess.F
+        cart2intgrad.F
+        lbfgs.F
+        kinetic_CASC.F
+        kinetic_lesyng.F
+        map.F
+        moments.F
+        muca_md.F
+        contact_cp.F
 ) 
 
 if(UNRES_DFA)
@@ -216,18 +225,18 @@ set_property(SOURCE ${UNRES_MDM_SRC3} PROPERTY COMPILE_FLAGS ${FFLAGS3} )
 #=========================================
 if(UNRES_MD_FF STREQUAL "GAB" )
   # set preprocesor flags   
-  set(CPPFLAGS "PROCOR -DUNRES -DISNAN -DSPLITELE -DLANG0 -DCRYST_BOND -DCRYST_THETA -DCRYST_SC" )
+  set(CPPFLAGS "PROCOR -DUNRES -DISNAN -DSPLITELE -DLANG0 -DCRYST_BOND -DCRYST_THETA -DCRYST_SC -DFOURBODY" )
 
 #=========================================
 #  Settings for E0LL2Y force field
 #=========================================
 elseif(UNRES_MD_FF STREQUAL "E0LL2Y")
   # set preprocesor flags   
-  set(CPPFLAGS "PROCOR -DUNRES -DISNAN -DSPLITELE -DLANG0" )
+  set(CPPFLAGS "PROCOR -DUNRES -DISNAN -DSPLITELE -DLANG0 -DFOURBODY" )
 elseif(UNRES_MD_FF STREQUAL "4P")
-  set(CPPFLAGS "UNRES -DISNAN -DSPLITELE -DLANG0 -DCRYST_BOND -DCRYST_THETA -DCRYST_SC -DSCCORPDB" )
+  set(CPPFLAGS "UNRES -DISNAN -DSPLITELE -DLANG0 -DCRYST_BOND -DCRYST_THETA -DCRYST_SC -DSCCORPDB -DFOURBODY" )
 elseif(UNRES_MD_FF STREQUAL "NEWCORR")
-  set(CPPFLAGS "PROCOR -DUNRES -DISNAN -DSPLITELE -DLANG0 -DNEWCORR -DCORRCD" )
+  set(CPPFLAGS "PROCOR -DUNRES -DISNAN -DSPLITELE -DLANG0 -DNEWCORR -DCORRCD -DFIVEDIAG -DLBFGS" )
 endif(UNRES_MD_FF STREQUAL "GAB")
 
 if(UNRES_DFA)
@@ -293,13 +302,13 @@ set_property(SOURCE ${UNRES_MDM_PP_SRC} PROPERTY COMPILE_DEFINITIONS ${CPPFLAGS}
 if(UNRES_WITH_MPI) 
   # binary with mpi
   if(UNRES_DFA)
-   set(UNRES_BIN "unresMD-mult_${Fortran_COMPILER_NAME}_MPI_${UNRES_MD_FF}_DFA.exe")
+   set(UNRES_BIN "unresMD-mult_${Fortran_COMPILER_NAME}_MPI_${UNRES_MD_FF}_HCD-5D_DFA.exe")
   else(UNRES_DFA)
-   set(UNRES_BIN "unresMD-mult_${Fortran_COMPILER_NAME}_MPI_${UNRES_MD_FF}.exe")
+   set(UNRES_BIN "unresMD-mult_${Fortran_COMPILER_NAME}_MPI_${UNRES_MD_FF}_HCD-5D.exe")
   endif(UNRES_DFA)
 else(UNRES_WITH_MPI)
   # binary without mpi
-  set(UNRES_BIN "unresMD-mult_${Fortran_COMPILER_NAME}_single_${UNRES_MD_FF}.exe")
+  set(UNRES_BIN "unresMD-mult_${Fortran_COMPILER_NAME}_single_${UNRES_MD_FF}_HCD-5D.exe")
 endif(UNRES_WITH_MPI)  
 
 #=========================================