adding in cmake UNRES_MD_FF = 4P for wham and cluster
[unres.git] / source / cluster / wham / src-M / CMakeLists.txt
index c85a6b7..a9c8e1f 100644 (file)
@@ -91,6 +91,8 @@ if(UNRES_MD_FF STREQUAL "GAB" )
 elseif(UNRES_MD_FF STREQUAL "E0LL2Y")
    # set preprocesor flags   
    set(CPPFLAGS "PROCOR  -DSPLITELE -DSCCORPDB" )
+elseif(UNRES_MD_FF STREQUAL "4P")
+  set(CPPFLAGS "SPLITELE -DLANG0 -DCRYST_BOND -DCRYST_THETA -DCRYST_SC -DSCCORPDB" )
 endif(UNRES_MD_FF STREQUAL "GAB")
 
 #=========================================
@@ -138,7 +140,7 @@ set_property(SOURCE proc_proc.c PROPERTY COMPILE_DEFINITIONS "LINUX -DPGI" )
 #========================================
 #  Setting binary name
 #========================================
-set(UNRES_CLUSTER_WHAM_M_BIN "cluster_wham-M_${Fortran_COMPILER_NAME}.exe")
+set(UNRES_CLUSTER_WHAM_M_BIN "cluster_wham-mult_${Fortran_COMPILER_NAME}_MPI_${UNRES_MD_FF}.exe")
 
 #=========================================
 # Set full unres CLUSTER sources