ctest on cray with srun all tests
[unres.git] / source / cluster / wham / src-M / CMakeLists.txt
index 0293d15..51a1ad6 100644 (file)
@@ -183,6 +183,14 @@ install(TARGETS UNRES_CLUSTER_WHAM_M_BIN DESTINATION ${CMAKE_INSTALL_PREFIX}/clu
      set (boot_lam "")
   endif()
 
+  if (UNRES_SRUN)
+   set (np "-n")
+   set (mpiexec "srun")
+  else()
+   set (np "-np")
+   set (mpiexec "mpiexec")
+  endif()
+
 
 FILE(WRITE ${CMAKE_CURRENT_BINARY_DIR}/scripts/cluster_wham_mpi_E0LL2Y.sh
 "#!/bin/sh
@@ -215,7 +223,7 @@ export SIDEP=$DD/contact.3.parm
 export SCRATCHDIR=.
 #-----------------------------------------------------------------------------
 echo CTEST_FULL_OUTPUT
-mpiexec ${boot_lam} -np $2 $CLUSTER_WHAM_BIN 
+${mpiexec} ${boot_lam} ${np} $2 $CLUSTER_WHAM_BIN 
 ./cluster_wham_check.sh $1 
 ")