bug fix after Ana and cluster lipid (still in progress)
[unres.git] / source / cluster / wham / src-M / CMakeLists.txt
index 5597466..30193dd 100644 (file)
@@ -37,6 +37,7 @@ set(UNRES_CLUSTER_WHAM_M_SRC0
        rescode.f
        setup_var.f
        srtclust.f
+    ssMD.F
        timing.F
        track.F
        wrtclust.f
@@ -52,6 +53,7 @@ set(UNRES_CLUSTER_WHAM_M_PP_SRC
        probabl.F
        read_coords.F
        readrtns.F
+    ssMD.F
        timing.F
        track.F
        work_partition.F
@@ -62,7 +64,7 @@ set(UNRES_CLUSTER_WHAM_M_PP_SRC
 # Set comipiler flags for different sourcefiles  
 #================================================
 if (Fortran_COMPILER_NAME STREQUAL "ifort")
-  set(FFLAGS0 "-ip -w -I. -I${CMAKE_CURRENT_SOURCE_DIR}/include_unres"  ) 
+  set(FFLAGS0 "-mcmodel=medium -shared-intel -ip -w -I. -I${CMAKE_CURRENT_SOURCE_DIR}/include_unres"  ) 
 elseif (Fortran_COMPILER_NAME STREQUAL "gfortran")
   set(FFLAGS0 "-std=legacy -I. -I${CMAKE_CURRENT_SOURCE_DIR}/include_unres" ) 
 else ()
@@ -103,7 +105,7 @@ set(CPPFLAGS "${CPPFLAGS} -DUNRES -DISNAN")
 #=========================================
 if (Fortran_COMPILER_NAME STREQUAL "ifort")
   # Add ifort preprocessor flags
-  set(CPPFLAGS "${CPPFLAGS} -DPGI") 
+  set(CPPFLAGS "${CPPFLAGS} -DPGI" ) 
 elseif (Fortran_COMPILER_NAME STREQUAL "f95")
   # Add new gfortran flags
   set(CPPFLAGS "${CPPFLAGS} -DG77")